Ruby: Could not find a JavaScript runtime

полный текст ошибки:

Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

Традиционное


добавьте в Gemfile параметры:
gem 'execjs'
gem 'therubyracer'

И не забудте сделать:
bundle install

мне не помогло. Разумеется, ходил на https://github.com/sstephenson/execjs и ставил все подряд варианты. Mustang, therubyracer, johnson не помоли, а вот Node.js - помог.
К сожалению его не получалось поставить по-быстрому из пакетов, но сборка из исходников проблем не вызвала.
Идем на http://nodejs.org, а дальше все традиционно: ./configure, make && make install

» »

Оставить комментарий - Feel free to ask me in English

Он появится после того, как будет одобрен. - All comments are pre-moderated.

Внимание! Пожалуйста, не пишите в комментарии [url=... или [url]... - это будет считаться спамом. Если хотите дать ссылку - пишите просто адрес, до 2х на один коммент.
Attention! Please don't use "[url=..." or "[url]..." in comment's body or it will be deleted as spam
If you want to send me a link just type url, up to 2 urls in one comment.

Спасибо за отзыв! Thank you for a comment!